Applies to: Info-Retriever 2005 and above
Issue:
Attached files are not accessible from all computers on the network. Or, attached files that are located on a central server may no longer be accessible if the files need to be moved to a different server. There are two solutions that you can adopt to lesson or eliminate this issue.
Cause:
This issue is caused when a file is attached using the drive letter and folder on the user's local hard drive instead of using a network location such as a UNC computer name or mapped network drive.
For example, John attaches a file that is located on his C: drive. When he attaches it, he enters it as "C:\Attachments\sample.dwg". Later, Bob tries to access this attached file from his computer, but Info-Retriever reports that the file is not there. This is because the file is on John's C: drive and not Bob's.
The correct method would have been for John to attach the file using a computer name such as "\\Johns Computer\Attachments\sample.dwg", or by using a mapped network drive that is available to everyone in the office, such as "M:\Sample.dwg". (Taking this a step farther, the best method would be for John to save this attached file on the server, and not on his computer.)
These methods are described in greater detail below.
Solution 1 - using a computer name:
Whenver you save (or attach to) a file on your server, always browse to that file using the "Computer Name". For instance, \\Server1\Files\sample.dwg If you later need to move the files to a different computer, then if you rename the new computer to the old name "Server1" you will still be able to access your files. (of course, the old computer will need to be renamed to something else to avoid any naming conflicts on the network.) Also, these types of computer names are known as "UNC" names in case you want to research this further on the internet.
Solution 2 - using a mapped network drive:
Create a folder on your server and then on each workstation, "Map" this folder to a drive letter. For instance, on your server you might create a folder on drive C: called "C:\Attachments". (Also, be sure to set the "Share" properties for this folder so other computers on the network can see it.)
Then, on each workstation:
- Start Windows Explorer
- Click on the Tools menu
- Select "Map Network Drive"
- In the "Drive" field, select a drive letter that can be used by each workstation, for instance, "M:"
- In the "Folder" field, browse to folder on your server, for instance \\Server1\Attachments
- Make sure the "Reconnect at logon" checkbox is checked.
* Note: Be sure to do this for each workstation. Also, be sure to use the same drive letter for each workstation.

Now, whenever you attach a file from that folder, just make sure you
do so using the new "mapped" drive letter. For example, if you had a
file on the server called "C:\Attachments\Sample.dwg", then from any
computer (including the server), you would always refer to it as
"M:\Sample.dwg".
Again, if you ever have to move the files to a different computer, then
you can still get to the new location by going to each workstation and
changing the mapped drive "M:" to point to the new location.
Regardless of which solution you use, always keep the following in mind:
Whether you use the computer name, or a mapped drive letter, always use the same one from each of your workstations (and server).
Never use the local drive letter when attaching a file in Info-Retriever. For instance, Never use "C:\Attachments\Sample.dwg" Instead, use the computer name, such as \\Server1\Attachments\Sample.dwg", or a mapped drive letter such as "M:\Sample.dwg".
Although the above guidelines will not address any issues with files that you've already attached, it will allow any attachments that you make from here on to be more easily migrated to a different location in the future.